Can't get URLs to expand. What am I doing wrong?


Hi, guys. No matter how much I try, I can’t get URLs from my site to expand in the forums. The issue is isolated to growella dot com sites, only.

How have you guys overcome this one?





This problem can be tricky. Discourse (the software that runs these forums) uses a featured called “OneBox” that, in turn, utilizes Facebook’s OpenGraph to embed web page previews.

I used one of your URLs to test in their debugger tool, and it says that your site is missing the required Facebook App ID:

To my knowledge, you don’t strictly need to include that attribute (my site doesn’t include that, yet my embeds work just fine). That’s because I’m using a plugin (MashShare) that includes the OpenGraph meta tags into my site.

You may want to look into a plugin like MashShare or another one that specifically adds in Open Graph meta tags into your site, like this:


Steve, your knowledge about the most random (I think) things astounds me.


Hah! Thanks - but, my knowledge of typical pop culture that most other people know…I probably don’t.

It’s weird…


Open graph (and other things I don’t understand) > pop culture in usefulness :)!


Oh, I love the way you think! :slight_smile:


Thanks, everyone. This is linked to Yoast SEO. I’m digging and will report back.

Thanks again.


Any progress, Dan?


Still nothing. Thanks for the reminder. I’ll keep at it.


Doesn’t seem to have errors. Click this to see.


What have you tried thus far to fix the problem?


I tried to install open graph but gave me a conflict with Yoast SEO. Still having the same issue. When I post the same link on facebook, twitter, etc the preview appears.


This describes my issue as well.

I’ve tested other, non-Growella links on RSF successfully. So, it’s not my browser configuration.

I’ve tested Growella links on non-RSF sites unsuccessfully. So, it’s not a problem with RSF.

I’ll continue to dig. I’m sure it’s something small in a config file or something.


Still no luck, btw. Not sure what’s up.


Same for me.


Just the two of us, @DebtDiscipline? Is anyone else affected?


Same here. I wish I was more tech savy.


Same URL works fine on facebook, just not here on the forums.


Believe @method_money is experiencing a similar issue, as evidenced here. Good luck, guys!